Проблема с отображением в Modo 901

Главные вкладки

10 сообщений [Последнее сообщение]

Dmi3ryd

с mymodo 2785 дней
430
Голос за!
0
Голос против!

модонафт

GameDevLuxology Galleryздбрашикмодонафт

Всем, привет.

В модо 901 появилась странная проблема связанная с скоростью выделения поликов или других компонентов меша (лучше всего видно на поликах).

Суть проблемы заключается в следующем.

Если подвести курсором к обьекту, в режимее поликов, то полигоны подсвечиваются, вообщем то тут нет ничего особенного.

Если нажать, то выделяются.

При создании любого примитива, и попытке поводить курсором по компонентам, полигонам, модо начинает тормозить.

Если делать это медленно, очень медленно, то все ок. Если чуть ускорить движение курсора то, создается впечатление подтормаживания.

Т.е. такое ощущение что программма не успевает просчитывать over selection. 

Раньше, в 801 и на другом компьютере, в 901 у меня такого не было.

Сбрасывал конфиг, не помогает.

Железо Win 8.1, Asus GTX 780TI, 24 оперативы, SSD. Драйвера видео, свежие.

Кто-нибудь сталкивался с похожим?

ammbass

с mymodo 2918 дней
5895
Голос за!
45
Голос против!

злой коллибри

Автор обучающих материалов на MyModo.ruАммбасс

В эдванс опенгл возможно могут быть тормоза. Но не знаю, у меня корректно работает.

Автор

Dmi3ryd

с mymodo 2785 дней
430
Голос за!
0
Голос против!

модонафт

GameDevLuxology Galleryздбрашикмодонафт

Исключено, потому, как на другом компе все работает хорошо. А также на этом компе в версии 801.

APEC

с mymodo 2142 дня
1464
Голос за!
39
Голос против!

с МОДО веселей :)

Автор обучающих материалов на MyModo.ruАммбассДжедайЧеловек дела

если на других машинах работало нормально, значит логически предположить, что дело в железе или софте которое не хочет дружить с модо.

что нужно попробовать:

1. переключиться из адвансед опен ГЛ на какой то другой и попробовать тот же эксперемент, что описан у вас выше.

2. отключить VBO в настройках модо. Preferences - Display - OpenGL - VBO Mode

Автор

Dmi3ryd

с mymodo 2785 дней
430
Голос за!
0
Голос против!

модонафт

GameDevLuxology Galleryздбрашикмодонафт

1. Тем более :)

2. VBO не может по умолчанию давать такой эффект, т.к. наоборот ускоряет отрисовку геометрии, особенно тяжелой сетки.

APEC

с mymodo 2142 дня
1464
Голос за!
39
Голос против!

с МОДО веселей :)

Автор обучающих материалов на MyModo.ruАммбассДжедайЧеловек дела

Dmi3ryd wrote:

1. Тем более :) 2. VBO не может по умолчанию давать такой эффект, т.к. наоборот ускоряет отрисовку геометрии, особенно тяжелой сетки.

значит 100% железо-софт сторонний. Возможно ССД както плохо реагирует на обрашение программы модо к диску в тот момент как курсор наводится на полигон. Или видеокарта, попробуйте дрова не свежие, а прошлой версии.

 

Автор

Dmi3ryd

с mymodo 2785 дней
430
Голос за!
0
Голос против!

модонафт

GameDevLuxology Galleryздбрашикмодонафт

Нашел решение:

http://community.thefoundry.co.uk/discussion/topic.aspx?f=32&t=115249

Может кому пригодится.

root

с mymodo 1072 дня
757
Голос за!
13
Голос против!

пакацукатак

АммбассМедаль ТролляЧеловек дела

Просто в настройках мыши проблема.) Круто!))

diggre

с mymodo 1230 дней
41
Голос за!
0
Голос против!

Как работает View > Show Vertex Normals? Полигональные нормали включаются нормально, а вершинные что-то никак.(

diggre

с mymodo 1230 дней
41
Голос за!
0
Голос против!

Разобрался: для срабатывания команды необходимо присвоить Vertex Map. Но почему в несглаженном состоянии меша (face) из вершин торчит только одна нормаль (как при сглаживании), а не черыре?

Пардон, в каком состоянии создана карта,- таким и будет отображение.